CVE-2024-1338

CVSS 3.1 Score 4.3 of 10 (medium)

Details

Published Feb 29, 2024

Summary

The vulnerability with CVE ID CVE-2024-1338 affects the ImageRecycle pdf & image compression plugin for WordPress, specifically versions up to and including 3.1.13. It is vulnerable to Cross-Site Request Forgery due to missing or incorrect nonce validation on the stopOptimizeAll function. This vulnerability allows unauthenticated attackers to modify image optimization settings by tricking a site administrator into performing an action, such as clicking on a link. The base severity of this vulnerability is rated as MEDIUM, with a base score of 4.3, and it requires user interaction and network access for exploitation. The potential danger this vulnerability poses to an organization is low integrity impact and no confidentiality impact, but it can lead to unauthorized modification of image optimization settings. To remediate this vulnerability, users should update to the latest version of the plugin when it becomes available.

Explore Beyond the CVE Basics with Recorded Future's Vulnerability Intelligence

Note: This is just a basic overview providing quick insights into CVE-2024-1338 information. Gain full access to comprehensive CVE data, risk scores, prioritization, and mitigation data through Recorded Future's Vulnerability Intelligence:
  • Prioritize with Risk-Based Scoring
  • Explore the Extensive Vulnerability Database
  • Receive Early Alerts on Emerging CVEs
  • Focus on Critical Exploitable Vulnerabilities
  • Streamline Remediation with Integration Options