CVE-2024-1080

CVSS 3.1 Score 6.4 of 10 (medium)

Details

Published Mar 13, 2024

Summary

CVE-2024-1080 is a vulnerability affecting the Beaver Builder – WordPress Page Builder plugin for WordPress. The vulnerability allows authenticated attackers with contributor access and above to inject arbitrary web scripts into pages using the heading tag. This can lead to stored cross-site scripting, where the injected scripts will execute whenever a user accesses an injected page. The vulnerability exists in all versions up to and including 2.7.4.4 of the plugin. To remediate this vulnerability, users should update to a version that includes the necessary input sanitization and output escaping measures. This vulnerability poses a medium risk with a base severity score of 6.4 out of 10 and low privileges required for exploitation, no user interaction needed, and a low impact on integrity and confidentiality.

Explore Beyond the CVE Basics with Recorded Future's Vulnerability Intelligence

Note: This is just a basic overview providing quick insights into CVE-2024-1080 information. Gain full access to comprehensive CVE data, risk scores, prioritization, and mitigation data through Recorded Future's Vulnerability Intelligence:
  • Prioritize with Risk-Based Scoring
  • Explore the Extensive Vulnerability Database
  • Receive Early Alerts on Emerging CVEs
  • Focus on Critical Exploitable Vulnerabilities
  • Streamline Remediation with Integration Options