CVE-2024-0963

CVSS 3.1 Score 6.4 of 10 (medium)

Details

Published Feb 2, 2024
Updated: Feb 8, 2024
CWE ID 79

Summary

CVE-2024-0963 is a vulnerability found in the Calculated Fields Form plugin for WordPress, affecting all versions up to and including 1.2.52. The vulnerability allows authenticated attackers with contributor-level and above permissions to exploit stored cross-site scripting (XSS) by injecting arbitrary web scripts through the plugin's CP_CALCULATED_FIELDS shortcode. Insufficient input sanitization and output escaping on the 'location' attribute make it possible for these scripts to execute when a user accesses an injected page. The vulnerability has a risk score of 25 and a base severity of MEDIUM. To remediate the issue, users should update to the latest version of the plugin as soon as possible. This vulnerability poses a potential danger to organizations using the affected plugin, as it could lead to unauthorized script execution and potential compromise of user data or website integrity.

Explore Beyond the CVE Basics with Recorded Future's Vulnerability Intelligence

Note: This is just a basic overview providing quick insights into CVE-2024-0963 information. Gain full access to comprehensive CVE data, risk scores, prioritization, and mitigation data through Recorded Future's Vulnerability Intelligence:
  • Prioritize with Risk-Based Scoring
  • Explore the Extensive Vulnerability Database
  • Receive Early Alerts on Emerging CVEs
  • Focus on Critical Exploitable Vulnerabilities
  • Streamline Remediation with Integration Options