CVSS 3.1 Score 7.2 of 10 (high)


Published Feb 5, 2024
Updated: Feb 13, 2024
CWE ID 434


CVE-2024-0699 is a vulnerability that affects the AI Engine: Chatbots, Generators, Assistants, GPT 4, and more! plugin for WordPress versions up to and including 2.1.4. The vulnerability allows authenticated attackers with Editor access and above to upload arbitrary files on the affected site's server, potentially leading to remote code execution. The vulnerability is due to missing file type validation in the 'add_image_from_url' function. Organizations can remediate this vulnerability by updating the plugin to a fixed version or by disabling it until a patch becomes available. This vulnerability has a high base severity score of 7.2 and poses a potential danger to organizations as it can be exploited remotely without user interaction, compromising the integrity and confidentiality of the affected system.

Prevent cyber attacks with Recorded Future by prioritizing and patching critical vulnerabilities being exploited by threat actors targeting your industry. Book your demo to learn more.


Prioritize, Pinpoint, and Act to Prevent Vulnerability Exploits with Recorded Future

Note: This is just a basic overview providing quick insights into CVE-2024-0699 information. Gain full access to comprehensive CVE data, third party vulnerabilities, compromised credentials and more with Recorded Future
  • Gain complete coverage of your cyber, third party, and physical attack surface
  • Proactively mitigate threats before they turn into costly attacks
  • Make fast, effective, data-driven decisions