CVE-2024-0630

CVSS 3.1 Score 4.4 of 10 (medium)

Details

Published Feb 5, 2024
Updated: Feb 13, 2024
CWE ID 79

Summary

CVE-2024-0630 is a vulnerability affecting the WP RSS Aggregator plugin for WordPress in versions up to 4.23.4, which allows for Stored Cross-Site Scripting (XSS) attacks. The vulnerability arises due to insufficient input sanitization and output escaping, enabling authenticated attackers with administrator-level access to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. This vulnerability only affects multi-site installations and installations where unfiltered_html has been disabled. The potential danger lies in the ability of attackers to execute arbitrary code on affected websites, potentially leading to unauthorized access, data theft, or further compromise of the WordPress installation. To remediate this vulnerability, users are advised to update the WP RSS Aggregator plugin to a version beyond 4.23.4 as soon as possible.

Explore Beyond the CVE Basics with Recorded Future's Vulnerability Intelligence

Note: This is just a basic overview providing quick insights into CVE-2024-0630 information. Gain full access to comprehensive CVE data, risk scores, prioritization, and mitigation data through Recorded Future's Vulnerability Intelligence:
  • Prioritize with Risk-Based Scoring
  • Explore the Extensive Vulnerability Database
  • Receive Early Alerts on Emerging CVEs
  • Focus on Critical Exploitable Vulnerabilities
  • Streamline Remediation with Integration Options