CVE-2024-0514

CVSS 3.1 Score 4.3 of 10 (medium)

Details

Published Feb 29, 2024

Summary

The CVE-2024-0514 vulnerability affects the Royal Elementor Addons and Templates plugin for WordPress up to version 1.3.87. It is vulnerable to Cross-Site Request Forgery (CSRF) due to missing or incorrect nonce validation on the add_to_compare function. This allows unauthenticated attackers to add items to user compare lists by tricking a site administrator into performing an action, such as clicking on a link. The vulnerability has a risk score of 5, a base severity of MEDIUM, and requires user interaction over a network. Remediation for this vulnerability involves updating the plugin to a version that addresses the issue. The potential danger it poses to organizations is the unauthorized manipulation of user compare lists, which could lead to confusion, false information, or malicious activities on affected WordPress websites.

Explore Beyond the CVE Basics with Recorded Future's Vulnerability Intelligence

Note: This is just a basic overview providing quick insights into CVE-2024-0514 information. Gain full access to comprehensive CVE data, risk scores, prioritization, and mitigation data through Recorded Future's Vulnerability Intelligence:
  • Prioritize with Risk-Based Scoring
  • Explore the Extensive Vulnerability Database
  • Receive Early Alerts on Emerging CVEs
  • Focus on Critical Exploitable Vulnerabilities
  • Streamline Remediation with Integration Options