CVE-2024-0405

CVSS 3.1 Score 7.2 of 10 (high)

Details

Published Jan 17, 2024
Updated: Jan 24, 2024
CWE ID 89

Summary

CVE-2024-0405 is a vulnerability in the Burst Statistics – Privacy-Friendly Analytics for WordPress plugin, specifically affecting version 1.5.3. The vulnerability allows for Post-Authenticated SQL Injection through multiple JSON parameters in the /wp-json/burst/v1/data/compare endpoint. Parameters such as 'browser', 'device', 'page_id', 'page_url', 'platform', and 'referrer' are affected. This vulnerability is due to inadequate escaping of user-supplied parameters and insufficient preparation in SQL queries, which enables authenticated attackers with editor access or higher to inject additional SQL queries and potentially gain unauthorized access to sensitive information in the database. The vulnerability has a base severity score of 7.2 (HIGH) and poses a high risk to confidentiality and integrity. Affected products include various versions of WordPress plugins with IDs: uREVKK, uREVKI, uREVKJ, uREVKC, uREVKD, uREVKA, uREVKB, uREVKG, uREVKH, uREVKE, uREVKF, uREVJ6, uREVJ7, uREVJ4, uREVJ5, uREVJ-, t0W1s1, uREVJ_, uREVJ8, t0W1s2,t0W1s3,uREVJ9,t0W1s4,uREVJz,t0W1s5,t0W1s6,t0W1s7,uREVJ2,t0W1s8,t0W1s9,uREVJ3,uREVJ0,anduREVJ1

Explore Beyond the CVE Basics with Recorded Future's Vulnerability Intelligence

Note: This is just a basic overview providing quick insights into CVE-2024-0405 information. Gain full access to comprehensive CVE data, risk scores, prioritization, and mitigation data through Recorded Future's Vulnerability Intelligence:
  • Prioritize with Risk-Based Scoring
  • Explore the Extensive Vulnerability Database
  • Receive Early Alerts on Emerging CVEs
  • Focus on Critical Exploitable Vulnerabilities
  • Streamline Remediation with Integration Options