CVE-2023-7224

CVSS 3.1 Score 7.8 of 10 (high)

Details

Published Jan 8, 2024
Updated: Jan 11, 2024
CWE ID 94
CWE ID 95

Summary

CVE-2023-7224 is a cyber vulnerability that affects OpenVPN Connect version 3.0 through 3.4.6 on macOS. It allows local users to execute code in external third-party libraries by exploiting the DYLD_INSERT_LIBRARIES environment variable. The vulnerability has a base severity rating of HIGH and poses a potential danger to organizations as it can lead to code injection and compromise the integrity and confidentiality of the system. To remediate this vulnerability, users should update their OpenVPN Connect software to a version beyond 3.4.6, where the issue has been addressed.

Explore Beyond the CVE Basics with Recorded Future's Vulnerability Intelligence

Note: This is just a basic overview providing quick insights into CVE-2023-7224 information. Gain full access to comprehensive CVE data, risk scores, prioritization, and mitigation data through Recorded Future's Vulnerability Intelligence:
  • Prioritize with Risk-Based Scoring
  • Explore the Extensive Vulnerability Database
  • Receive Early Alerts on Emerging CVEs
  • Focus on Critical Exploitable Vulnerabilities
  • Streamline Remediation with Integration Options