CVE-2023-7101

CVSS 3.1 Score 7.8 of 10 (high)

Details

Published Dec 24, 2023
Updated: Jan 9, 2024
CWE ID 94
CWE ID 95

Summary

CVE-2023-7101 is a vulnerability found in Spreadsheet::ParseExcel version 0.65, a Perl module used for parsing Excel files. The vulnerability allows for arbitrary code execution due to passing unvalidated input from a file into a string-type "eval" function. The issue specifically arises from the evaluation of Number format strings within the Excel parsing logic. This vulnerability affects multiple products, including versions 0.65 and below of Spreadsheet::ParseExcel. To remediate this vulnerability, users are advised to update to the latest version of Spreadsheet::ParseExcel (version 0.66 or later) which includes a fix for this issue. This vulnerability poses a high risk to organizations as it can lead to unauthorized code execution, potentially allowing attackers to gain control over affected systems and access sensitive data.

Explore Beyond the CVE Basics with Recorded Future's Vulnerability Intelligence

Note: This is just a basic overview providing quick insights into CVE-2023-7101 information. Gain full access to comprehensive CVE data, risk scores, prioritization, and mitigation data through Recorded Future's Vulnerability Intelligence:
  • Prioritize with Risk-Based Scoring
  • Explore the Extensive Vulnerability Database
  • Receive Early Alerts on Emerging CVEs
  • Focus on Critical Exploitable Vulnerabilities
  • Streamline Remediation with Integration Options