CVE-2023-6911

CVSS 3.1 Score 4.8 of 10 (medium)

Details

Published Dec 18, 2023
Updated: Dec 22, 2023
CWE ID 79

Summary

CVE-2023-6911 is a vulnerability that affects multiple WSO2 products. The vulnerability is due to improper output encoding, which allows for a Stored Cross Site Scripting (XSS) attack. An attacker can inject a malicious payload into the Registry feature of the Management Console. This vulnerability has a risk score of 25 and a base severity of MEDIUM according to NIST. It requires HIGH privileges and user interaction is required for exploitation. The attack vector is through the network, and the impact on integrity and confidentiality is low. Remediation steps should be taken by WSO2 to address this vulnerability and prevent potential danger to organizations using these affected products.

Explore Beyond the CVE Basics with Recorded Future's Vulnerability Intelligence

Note: This is just a basic overview providing quick insights into CVE-2023-6911 information. Gain full access to comprehensive CVE data, risk scores, prioritization, and mitigation data through Recorded Future's Vulnerability Intelligence:
  • Prioritize with Risk-Based Scoring
  • Explore the Extensive Vulnerability Database
  • Receive Early Alerts on Emerging CVEs
  • Focus on Critical Exploitable Vulnerabilities
  • Streamline Remediation with Integration Options