CVSS 3.1 Score 6.4 of 10 (medium)


Published Feb 5, 2024
Updated: Feb 27, 2024


CVE-2023-6807 is a vulnerability affecting the GeneratePress Premium plugin for WordPress in versions up to and including 2.3.2. It is categorized as a Stored Cross-Site Scripting vulnerability caused by insufficient input sanitization and output escaping on user supplied attributes. This vulnerability allows authenticated attackers with contributor-level or higher permissions to inject arbitrary web scripts in pages, which will execute whenever a user accesses the injected page. The vulnerability has a risk score of 25 and a base severity of MEDIUM. The affected products include various versions of the GeneratePress Premium plugin for WordPress. To remediate this vulnerability, users should update to version 2.3.3 or later of the plugin to ensure that proper input sanitization and output escaping measures are implemented. If left unpatched, an organization may be at risk of unauthorized code execution and potential compromise of user data or system integrity.


Explore Beyond the CVE Basics with Recorded Future's Vulnerability Intelligence

Note: This is just a basic overview providing quick insights into CVE-2023-6807 information. Gain full access to comprehensive CVE data, risk scores, prioritization, and mitigation data through Recorded Future's Vulnerability Intelligence:
  • Prioritize with Risk-Based Scoring
  • Explore the Extensive Vulnerability Database
  • Receive Early Alerts on Emerging CVEs
  • Focus on Critical Exploitable Vulnerabilities
  • Streamline Remediation with Integration Options