CVSS 3.1 Score 5.4 of 10 (medium)


Published Jan 4, 2024
Updated: Jan 10, 2024


CVE-2023-6738 is a vulnerability found in the Page Builder: Pagelayer plugin for WordPress versions up to and including 1.7.8. This vulnerability allows authenticated attackers with contributor-level permissions or higher to inject arbitrary web scripts into pages using the 'pagelayer_header_code', 'pagelayer_body_open_code', and 'pagelayer_footer_code' meta fields. When a user accesses an injected page, these scripts will execute, potentially leading to cross-site scripting attacks. The vulnerability is a result of insufficient input sanitization and output escaping on user-supplied attributes. Organizations using affected versions of the plugin should update to version 1.7.9 or later to remediate this vulnerability.

Explore Beyond the CVE Basics with Recorded Future's Vulnerability Intelligence

Note: This is just a basic overview providing quick insights into CVE-2023-6738 information. Gain full access to comprehensive CVE data, risk scores, prioritization, and mitigation data through Recorded Future's Vulnerability Intelligence:
  • Prioritize with Risk-Based Scoring
  • Explore the Extensive Vulnerability Database
  • Receive Early Alerts on Emerging CVEs
  • Focus on Critical Exploitable Vulnerabilities
  • Streamline Remediation with Integration Options