CVE-2023-6680

CVSS 3.1 Score 8.1 of 10 (high)

Details

Published Dec 15, 2023
Updated: Dec 19, 2023
CWE ID 295

Summary

CVE-2023-6680 is an improper certificate validation vulnerability in Smartcard authentication in GitLab EE. This vulnerability affects all versions from 11.6 prior to 16.4.4, 16.5 prior to 16.5.4, and 16.6 prior to 16.6.2 of GitLab EE. If an attacker uses Smartcard authentication, they can authenticate as another user given their public key. To remediate this vulnerability, administrators need to manually enable Smartcard authentication and update to version 16.4.4, 16.5.4, or 16.6.2 of GitLab EE or a later version once available. This vulnerability has a high severity rating with a base score of 8.1 according to NVD@nist.gov, and it poses a potential danger to organizations as it allows unauthorized access and impersonation of users through Smartcard authentication in GitLab EE.

Explore Beyond the CVE Basics with Recorded Future's Vulnerability Intelligence

Note: This is just a basic overview providing quick insights into CVE-2023-6680 information. Gain full access to comprehensive CVE data, risk scores, prioritization, and mitigation data through Recorded Future's Vulnerability Intelligence:
  • Prioritize with Risk-Based Scoring
  • Explore the Extensive Vulnerability Database
  • Receive Early Alerts on Emerging CVEs
  • Focus on Critical Exploitable Vulnerabilities
  • Streamline Remediation with Integration Options