CVSS 3.1 Score 9.8 of 10 (high)


Published Jan 15, 2024
Updated: Jan 19, 2024


CVE-2023-6623 is a critical vulnerability that affects the Essential Blocks WordPress plugin before version 4.4.3. This vulnerability allows unauthenticated attackers to overwrite local variables when rendering templates over the REST API, potentially leading to Local File Inclusion attacks. The vulnerability has a high impact on confidentiality and integrity, with a base score of 9.8 out of 10. To remediate this vulnerability, users should update their Essential Blocks WordPress plugin to version 4.4.3 or later. Organizations using the affected products should take immediate action to mitigate the potential danger posed by this vulnerability.

Explore Beyond the CVE Basics with Recorded Future's Vulnerability Intelligence

Note: This is just a basic overview providing quick insights into CVE-2023-6623 information. Gain full access to comprehensive CVE data, risk scores, prioritization, and mitigation data through Recorded Future's Vulnerability Intelligence:
  • Prioritize with Risk-Based Scoring
  • Explore the Extensive Vulnerability Database
  • Receive Early Alerts on Emerging CVEs
  • Focus on Critical Exploitable Vulnerabilities
  • Streamline Remediation with Integration Options