CVE-2023-6594

CVSS 3.1 Score 4.4 of 10 (medium)

Details

Published Jan 9, 2024
Updated: Jan 11, 2024
CWE ID 79

Summary

CVE-2023-6594 is a vulnerability that affects the WordPress Button Plugin MaxButtons plugin for WordPress in versions up to 9.7.4. It is categorized as a Stored Cross-Site Scripting vulnerability due to insufficient input sanitization and output escaping in the admin settings. This vulnerability allows authenticated attackers with administrator-level permissions or above to inject arbitrary web scripts into pages, which will execute whenever a user accesses an injected page. The danger of this vulnerability is limited to multi-site installations and installations where unfiltered_html has been disabled. Administrators can mitigate the risk by granting button creation privileges only to users with lower levels (contributor+) to prevent potential attacks.

Explore Beyond the CVE Basics with Recorded Future's Vulnerability Intelligence

Note: This is just a basic overview providing quick insights into CVE-2023-6594 information. Gain full access to comprehensive CVE data, risk scores, prioritization, and mitigation data through Recorded Future's Vulnerability Intelligence:
  • Prioritize with Risk-Based Scoring
  • Explore the Extensive Vulnerability Database
  • Receive Early Alerts on Emerging CVEs
  • Focus on Critical Exploitable Vulnerabilities
  • Streamline Remediation with Integration Options