CVE-2023-6516

CVSS 3.1 Score 7.5 of 10 (high)

Details

Published Feb 13, 2024
Updated: Mar 4, 2024

Summary

The vulnerability with the CVE ID CVE-2023-6516 affects BIND 9 versions 9.16.0 through 9.16.45 and 9.16.8-S1 through 9.16.45-S1. When the recursive resolver `named` tries to clean up its cache database, it may encounter delays if continuously processing certain query patterns, leading to an infinite growth of queued cleanup events over time and potentially exceeding the configured `max-cache-size` limit. This vulnerability has a high severity rating with a base score of 7.5 and an exploitability score of 3.9, posing a potential danger to organizations using affected versions of BIND 9. To remediate this vulnerability, users should update their BIND software to versions that address this issue provided by the vendor or apply any available patches or workarounds recommended by ISC (Internet Systems Consortium).

Leverage our Vulnerability Intelligence module to secure your systems now - get detailed insights on CVE-2024-37364. Book your demo today.

Share

Explore Beyond the CVE Basics with Recorded Future's Vulnerability Intelligence

Note: This is just a basic overview providing quick insights into CVE-2023-6516 information. Gain full access to comprehensive CVE data, risk scores, prioritization, and mitigation data through Recorded Future's Vulnerability Intelligence:
  • Prioritize with Risk-Based Scoring
  • Explore the Extensive Vulnerability Database
  • Receive Early Alerts on Emerging CVEs
  • Focus on Critical Exploitable Vulnerabilities
  • Streamline Remediation with Integration Options