CVE-2023-6393

CVSS 3.1 Score 5.3 of 10 (medium)

Details

Published Dec 6, 2023
Updated: Dec 12, 2023
CWE ID 200

Summary

CVE-2023-6393 is a vulnerability that affects the Quarkus Cache Runtime. It allows a malicious user to gain access to sensitive data by taking advantage of a POST request returning the response intended for another user. The vulnerability occurs when request processing uses a Uni cached using @CacheResult and the cached Uni reuses the initial "completion" context, causing the processing to switch to the cached Uni instead of the request context. To remediate this vulnerability, it is recommended to update to the latest version of Quarkus Cache Runtime. The potential danger posed by this vulnerability is considered medium, with a confidentiality impact rated as high.

Share

Explore Beyond the CVE Basics with Recorded Future's Vulnerability Intelligence

Note: This is just a basic overview providing quick insights into CVE-2023-6393 information. Gain full access to comprehensive CVE data, risk scores, prioritization, and mitigation data through Recorded Future's Vulnerability Intelligence:
  • Prioritize with Risk-Based Scoring
  • Explore the Extensive Vulnerability Database
  • Receive Early Alerts on Emerging CVEs
  • Focus on Critical Exploitable Vulnerabilities
  • Streamline Remediation with Integration Options