CVE-2023-6337

CVSS 3.1 Score 7.5 of 10 (high)

Details

Published Dec 8, 2023
Updated: Jan 12, 2024
CWE ID 770

Summary

CVE-2023-6337 is a vulnerability affecting HashiCorp Vault and Vault Enterprise versions 1.12.0 and newer. The vulnerability allows for a denial of service attack through memory exhaustion when handling large unauthenticated and authenticated HTTP requests. This can lead to the host running out of memory, resulting in Vault crashing. To remediate this vulnerability, users should update their Vault installation to version 1.15.4, 1.14.8, or 1.13.12, which include the necessary fixes. The potential danger posed by this vulnerability is high, as it can result in the disruption of services provided by Vault and potentially impact an organization's operations or data availability.

Share

Explore Beyond the CVE Basics with Recorded Future's Vulnerability Intelligence

Note: This is just a basic overview providing quick insights into CVE-2023-6337 information. Gain full access to comprehensive CVE data, risk scores, prioritization, and mitigation data through Recorded Future's Vulnerability Intelligence:
  • Prioritize with Risk-Based Scoring
  • Explore the Extensive Vulnerability Database
  • Receive Early Alerts on Emerging CVEs
  • Focus on Critical Exploitable Vulnerabilities
  • Streamline Remediation with Integration Options