CVE-2023-5752

CVSS 3.1 Score 3.3 of 10 (low)

Details

Published Oct 25, 2023
Updated: Apr 21, 2024
CWE ID 77

Summary

CVE-2023-5752 is a vulnerability that affects the pip package manager prior to version 23.3. When installing a package from a Mercurial VCS URL, the specified Mercurial revision can be exploited to inject arbitrary configuration options to the "hg clone" call. This vulnerability allows an attacker to modify the repository being installed by controlling the Mercurial configuration. It is important to note that this vulnerability only affects users who are installing packages from Mercurial. The potential danger this vulnerability poses to organizations is low, with a base severity rating of LOW and an impact score of 1.4 out of 10. To remediate this vulnerability, users should update their pip package manager to version 23.3 or newer.

Explore Beyond the CVE Basics with Recorded Future's Vulnerability Intelligence

Note: This is just a basic overview providing quick insights into CVE-2023-5752 information. Gain full access to comprehensive CVE data, risk scores, prioritization, and mitigation data through Recorded Future's Vulnerability Intelligence:
  • Prioritize with Risk-Based Scoring
  • Explore the Extensive Vulnerability Database
  • Receive Early Alerts on Emerging CVEs
  • Focus on Critical Exploitable Vulnerabilities
  • Streamline Remediation with Integration Options