CVSS 3.1 Score 6.5 of 10 (medium)


Published Nov 7, 2023
Updated: Nov 14, 2023


CVE-2023-5709 is a vulnerability found in the WD WidgetTwitter plugin for WordPress versions up to and including 1.0.9. The vulnerability allows authenticated attackers with contributor-level and above permissions to perform SQL Injection attacks by appending additional SQL queries into existing queries, potentially leading to the extraction of sensitive information from the database. This vulnerability has a base severity rating of MEDIUM, with a base score of 6.5 according to The affected products include various versions of the WD WidgetTwitter plugin for WordPress. To remediate this vulnerability, users should update their plugin to a version that includes the necessary escaping and preparation measures to prevent SQL Injection attacks.

Explore Beyond the CVE Basics with Recorded Future's Vulnerability Intelligence

Note: This is just a basic overview providing quick insights into CVE-2023-5709 information. Gain full access to comprehensive CVE data, risk scores, prioritization, and mitigation data through Recorded Future's Vulnerability Intelligence:
  • Prioritize with Risk-Based Scoring
  • Explore the Extensive Vulnerability Database
  • Receive Early Alerts on Emerging CVEs
  • Focus on Critical Exploitable Vulnerabilities
  • Streamline Remediation with Integration Options