CVE-2023-5638

CVSS 3.1 Score 6.4 of 10 (medium)

Details

Published Oct 19, 2023
Updated: Nov 7, 2023
CWE ID 79

Summary

CVE-2023-5638 is a vulnerability in the Booster for WooCommerce plugin for WordPress, affecting versions up to and including 7.1.2. The vulnerability allows authenticated attackers with contributor-level and above permissions to inject arbitrary web scripts using the 'wcj_image' shortcode. This can lead to stored cross-site scripting, where the injected scripts execute whenever a user accesses an affected page. The vulnerability is due to insufficient input sanitization and output escaping on user-supplied attributes. To remediate this vulnerability, users should update the plugin to a fixed version or apply any available patches. The potential danger of this vulnerability is that it can be exploited by attackers to execute malicious code, compromising the security of affected WordPress websites and potentially stealing sensitive information or conducting further attacks.

Explore Beyond the CVE Basics with Recorded Future's Vulnerability Intelligence

Note: This is just a basic overview providing quick insights into CVE-2023-5638 information. Gain full access to comprehensive CVE data, risk scores, prioritization, and mitigation data through Recorded Future's Vulnerability Intelligence:
  • Prioritize with Risk-Based Scoring
  • Explore the Extensive Vulnerability Database
  • Receive Early Alerts on Emerging CVEs
  • Focus on Critical Exploitable Vulnerabilities
  • Streamline Remediation with Integration Options