CVSS 3.1 Score 6.4 of 10 (medium)


Published Oct 20, 2023
Updated: Nov 7, 2023


CVE-2023-5614 is a vulnerability affecting the Theme Switcha plugin for WordPress, specifically versions up to and including 3.3. It is categorized as a Stored Cross-Site Scripting vulnerability due to insufficient input sanitization and output escaping on user supplied attributes. This vulnerability allows authenticated attackers with contributor-level and above permissions to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. The vulnerability has a base severity of MEDIUM, with a base score of 6.4 according to the CVSS:3.1 scoring system. The affected products include various versions of the Theme Switcha plugin (tJfV7y, tJfV7w, tJfV7x, etc.). To remediate this vulnerability, users should update the Theme Switcha plugin to a version that includes a fix for this issue. If left unpatched, this vulnerability poses potential danger to organizations by allowing attackers to execute malicious scripts on compromised websites.

Explore Beyond the CVE Basics with Recorded Future's Vulnerability Intelligence

Note: This is just a basic overview providing quick insights into CVE-2023-5614 information. Gain full access to comprehensive CVE data, risk scores, prioritization, and mitigation data through Recorded Future's Vulnerability Intelligence:
  • Prioritize with Risk-Based Scoring
  • Explore the Extensive Vulnerability Database
  • Receive Early Alerts on Emerging CVEs
  • Focus on Critical Exploitable Vulnerabilities
  • Streamline Remediation with Integration Options