CVSS 3.1 Score 5.4 of 10 (medium)


Published Oct 12, 2023
Updated: Nov 7, 2023


CVE-2023-5470 is a vulnerability in the Etsy Shop plugin for WordPress versions up to and including 3.0.4. It is classified as a Stored Cross-Site Scripting vulnerability, allowing authenticated attackers with contributor-level and above permissions to inject arbitrary web scripts via the 'etsy-shop' shortcode. This can result in the execution of malicious code whenever a user accesses an injected page. The affected products include various versions of the Etsy Shop plugin for WordPress. To remediate this vulnerability, users should update to a version of the plugin beyond 3.0.4 that includes input sanitization and output escaping improvements. The potential danger posed by this vulnerability lies in the ability for attackers to execute arbitrary scripts, potentially leading to unauthorized access or other malicious activities within an organization's WordPress site.

Explore Beyond the CVE Basics with Recorded Future's Vulnerability Intelligence

Note: This is just a basic overview providing quick insights into CVE-2023-5470 information. Gain full access to comprehensive CVE data, risk scores, prioritization, and mitigation data through Recorded Future's Vulnerability Intelligence:
  • Prioritize with Risk-Based Scoring
  • Explore the Extensive Vulnerability Database
  • Receive Early Alerts on Emerging CVEs
  • Focus on Critical Exploitable Vulnerabilities
  • Streamline Remediation with Integration Options