CVE-2023-5309

CVSS 3.1 Score 6.8 of 10 (medium)

Details

Published Nov 7, 2023
Updated: Nov 15, 2023
CWE ID 384

Summary

CVE-2023-5309 is a vulnerability that affects versions of Puppet Enterprise prior to 2021.7.6 and 2023.5, leading to broken session management for SAML implementations. The vulnerability has a risk score of 65 and a base severity of MEDIUM. It requires low privileges and has no user interaction, with an attack vector through the network. The potential danger includes high impact on integrity and confidentiality, but no availability impact. The CVE ID indicates that there have been 43 hits related to this vulnerability. The source of the information is security@puppet.com, and the analysis description is not available. The affected products include various versions of Puppet Enterprise, with multiple different identifiers provided in the text. Remediation information is not provided in the given text.

Explore Beyond the CVE Basics with Recorded Future's Vulnerability Intelligence

Note: This is just a basic overview providing quick insights into CVE-2023-5309 information. Gain full access to comprehensive CVE data, risk scores, prioritization, and mitigation data through Recorded Future's Vulnerability Intelligence:
  • Prioritize with Risk-Based Scoring
  • Explore the Extensive Vulnerability Database
  • Receive Early Alerts on Emerging CVEs
  • Focus on Critical Exploitable Vulnerabilities
  • Streamline Remediation with Integration Options