CVE-2023-52427

CVSS 3.1 Score 7.5 of 10 (high)

Details

Published Feb 11, 2024
Updated: Mar 21, 2024
CWE ID 770

Summary

CVE-2023-52427 is a vulnerability found in OpenDDS versions up to 3.27, which can lead to a segmentation fault when using a DataWriter with a large value of resource_limits.max_samples. The affected product is OpenDDS. The vendor has stated that the product is not designed to handle a max_samples value that exceeds the available memory on the system. This vulnerability has a high severity rating, with a base score of 7.5, and can be exploited remotely over a network without requiring any privileges or user interaction. It poses a potential danger to organizations as it could result in denial-of-service attacks due to the availability impact being rated as high.

Explore Beyond the CVE Basics with Recorded Future's Vulnerability Intelligence

Note: This is just a basic overview providing quick insights into CVE-2023-52427 information. Gain full access to comprehensive CVE data, risk scores, prioritization, and mitigation data through Recorded Future's Vulnerability Intelligence:
  • Prioritize with Risk-Based Scoring
  • Explore the Extensive Vulnerability Database
  • Receive Early Alerts on Emerging CVEs
  • Focus on Critical Exploitable Vulnerabilities
  • Streamline Remediation with Integration Options