CVE-2023-52277

CVSS 3.1 Score 7.8 of 10 (high)

Details

Published Dec 31, 2023
Updated: Jan 10, 2024
CWE ID 787

Summary

CVE-2023-52277 is a cyber vulnerability that affects RoyalTSX before version 6.0.2.1. It allows attackers to cause a denial of service or potentially have other unspecified impacts by exploiting a heap memory corruption issue and application crash when a user clicks on Test Connection with a long hostname in an RTSZ file. The vulnerability occurs during the processing of the SecureGatewayHost object in RAPortCheck.createNWConnection. The risk score for this vulnerability is 25, indicating a high severity level. It requires no privileges and user interaction is required for exploitation. The attack vector is local, and the impact includes high integrity and confidentiality impacts with high availability impact as well. Remediation for this vulnerability involves updating to the latest version of RoyalTSX (6.0.2.1) or applying any relevant patches or fixes provided by the vendor.

Explore Beyond the CVE Basics with Recorded Future's Vulnerability Intelligence

Note: This is just a basic overview providing quick insights into CVE-2023-52277 information. Gain full access to comprehensive CVE data, risk scores, prioritization, and mitigation data through Recorded Future's Vulnerability Intelligence:
  • Prioritize with Risk-Based Scoring
  • Explore the Extensive Vulnerability Database
  • Receive Early Alerts on Emerging CVEs
  • Focus on Critical Exploitable Vulnerabilities
  • Streamline Remediation with Integration Options