CVE-2023-51714

CVSS 3.1 Score 9.8 of 10 (high)

Details

Published Dec 24, 2023
Updated: Jan 4, 2024
CWE ID 190

Summary

CVE-2023-51714 is a critical vulnerability discovered in the HTTP2 implementation in Qt versions before 5.15.17, 6.x before 6.2.11, 6.3.x through 6.5.x before 6.5.4, and 6.6.x before 6.6.2. The vulnerability affects various products, including i0tey9, i0tey8, i0tey_, and others listed in the affected_products field. This vulnerability is related to an incorrect HPack integer overflow check in network/access/http2/hpacktable.cpp file. It has a CVSSv3 base score of 9.8 (Critical) and poses a high risk to organizations as it can be exploited remotely without requiring any privileges or user interaction, potentially leading to confidentiality and integrity impacts on the affected systems. The recommended remediation is to update Qt to version 5.15.17 or newer, 6.x to version 6.2.11 or newer, or upgrade to the latest available version within the affected Qt branches to mitigate this vulnerability (source: nvd@nist.gov).

Explore Beyond the CVE Basics with Recorded Future's Vulnerability Intelligence

Note: This is just a basic overview providing quick insights into CVE-2023-51714 information. Gain full access to comprehensive CVE data, risk scores, prioritization, and mitigation data through Recorded Future's Vulnerability Intelligence:
  • Prioritize with Risk-Based Scoring
  • Explore the Extensive Vulnerability Database
  • Receive Early Alerts on Emerging CVEs
  • Focus on Critical Exploitable Vulnerabilities
  • Streamline Remediation with Integration Options