CVE-2023-51702

CVSS 3.1 Score 6.5 of 10 (medium)

Details

Published Jan 24, 2024
Updated: Jan 30, 2024
CWE ID 312
CWE ID 532

Summary

CVE-2023-51702 is a vulnerability that affects Airflow versions 5.2.0 to 7.0.0. It occurs when using deferrable mode with a Kubernetes configuration file for authentication, as the file is stored in metadata without encryption, making it accessible to anyone with access to the metadata or triggerer log. This can potentially allow unauthorized access to the Kubernetes cluster. The issue was fixed in version 7.0.0, and users are advised to upgrade to this version to remediate the vulnerability. The vulnerability has a base severity of MEDIUM, with a base score of 6.5, and a high impact on confidentiality.

Explore Beyond the CVE Basics with Recorded Future's Vulnerability Intelligence

Note: This is just a basic overview providing quick insights into CVE-2023-51702 information. Gain full access to comprehensive CVE data, risk scores, prioritization, and mitigation data through Recorded Future's Vulnerability Intelligence:
  • Prioritize with Risk-Based Scoring
  • Explore the Extensive Vulnerability Database
  • Receive Early Alerts on Emerging CVEs
  • Focus on Critical Exploitable Vulnerabilities
  • Streamline Remediation with Integration Options