CVE-2023-51445

CVSS 3.1 Score 4.8 of 10 (medium)

Details

Published Mar 20, 2024
CWE ID 79

Summary

CVE-2023-51445 is a stored cross-site scripting (XSS) vulnerability in GeoServer, an open source software server for sharing and editing geospatial data. The vulnerability affects versions prior to 2.23.3 and 2.24.0. An authenticated administrator with workspace-level privileges can store a JavaScript payload in uploaded style/legend resources, which will execute in the context of another administrator's browser when viewed in the REST Resources API. Access to the REST Resources API is limited to full administrators by default, but granting non-administrators access should be carefully considered as it may expose sensitive information. The issue has been patched in versions 2.23.3 and 2.24.0. The vulnerability has a risk score of 25 and a base severity of MEDIUM according to the CVSS:3.1 vector string, indicating a potential threat to organizations using affected versions of GeoServer if not remediated promptly.

(Note: This summary is based on the provided information and does not include any additional analysis or opinions.)

Explore Beyond the CVE Basics with Recorded Future's Vulnerability Intelligence

Note: This is just a basic overview providing quick insights into CVE-2023-51445 information. Gain full access to comprehensive CVE data, risk scores, prioritization, and mitigation data through Recorded Future's Vulnerability Intelligence:
  • Prioritize with Risk-Based Scoring
  • Explore the Extensive Vulnerability Database
  • Receive Early Alerts on Emerging CVEs
  • Focus on Critical Exploitable Vulnerabilities
  • Streamline Remediation with Integration Options