CVE-2023-51388

CVSS 3.1 Score 9.8 of 10 (high)

Details

Published Feb 22, 2024
CWE ID 74

Summary

CVE-2023-51388 is a vulnerability found in Hertzbeat, a real-time monitoring system. The vulnerability exists in the CalculateAlarm.java file where the usage of AviatorEvaluator allows for script injection due to the lack of security policy configuration. This means that an attacker can inject AviatorScript code, which can execute any static method by default. The vulnerability has been fixed in version 1.4.1 of Hertzbeat. This vulnerability has a base severity rating of CRITICAL with a CVSS score of 9.8, indicating a high potential danger to organizations.

Explore Beyond the CVE Basics with Recorded Future's Vulnerability Intelligence

Note: This is just a basic overview providing quick insights into CVE-2023-51388 information. Gain full access to comprehensive CVE data, risk scores, prioritization, and mitigation data through Recorded Future's Vulnerability Intelligence:
  • Prioritize with Risk-Based Scoring
  • Explore the Extensive Vulnerability Database
  • Receive Early Alerts on Emerging CVEs
  • Focus on Critical Exploitable Vulnerabilities
  • Streamline Remediation with Integration Options