CVE-2023-51379

CVSS 3.1 Score 4.9 of 10 (medium)

Details

Published Dec 21, 2023
Updated: Dec 29, 2023
CWE ID 863

Summary

CVE-2023-51379 is an incorrect authorization vulnerability that affected GitHub Enterprise Server versions since 3.7. The vulnerability allowed issue comments to be updated with an improperly scoped token, but it did not grant unauthorized access to repository content as it required specific permissions. The vulnerability was fixed in versions 3.17.19, 3.8.12, 3.9.7, 3.10.4, and 3.11.1 of GitHub Enterprise Server. The potential danger posed by this vulnerability to an organization would depend on the sensitivity of the information within the affected repositories and the actions that could be performed with the improperly scoped token.

Explore Beyond the CVE Basics with Recorded Future's Vulnerability Intelligence

Note: This is just a basic overview providing quick insights into CVE-2023-51379 information. Gain full access to comprehensive CVE data, risk scores, prioritization, and mitigation data through Recorded Future's Vulnerability Intelligence:
  • Prioritize with Risk-Based Scoring
  • Explore the Extensive Vulnerability Database
  • Receive Early Alerts on Emerging CVEs
  • Focus on Critical Exploitable Vulnerabilities
  • Streamline Remediation with Integration Options