CVSS 3.1 Score 7.5 of 10 (high)


Published Oct 2, 2023
Updated: Oct 4, 2023
CWE ID 284


The vulnerability with the CVE ID name CVE-2023-5106 affects all versions of Ultimate-licensed GitLab EE prior to 16.2.8, 16.3.5, and 16.4.1. The vulnerability allows an attacker to impersonate users in CI pipelines through direct transfer group imports. This vulnerability has a high severity rating with a base score of 7.5 and an exploitability score of 3.9 according to The potential danger it poses to an organization is high, as it can lead to unauthorized access and manipulation of CI pipelines, potentially compromising the integrity of the organization's code and systems. To remediate this vulnerability, organizations should update their GitLab EE installations to version 16.2.8, 16.3.5, or 16.4.1 or later versions that have fixed this issue.

Explore Beyond the CVE Basics with Recorded Future's Vulnerability Intelligence

Note: This is just a basic overview providing quick insights into CVE-2023-5106 information. Gain full access to comprehensive CVE data, risk scores, prioritization, and mitigation data through Recorded Future's Vulnerability Intelligence:
  • Prioritize with Risk-Based Scoring
  • Explore the Extensive Vulnerability Database
  • Receive Early Alerts on Emerging CVEs
  • Focus on Critical Exploitable Vulnerabilities
  • Streamline Remediation with Integration Options