CVE-2023-5099

CVSS 3.1 Score 8.8 of 10 (high)

Details

Published Oct 31, 2023
Updated: Nov 13, 2023
CWE ID 552

Summary

CVE-2023-5099 is a vulnerability found in the HTML filter and csv-file search plugin for WordPress versions up to and including 2.7. This vulnerability allows authenticated attackers with contributor-level permissions or higher to exploit a Local File Inclusion (LFI) flaw through the 'src' attribute of the 'csvsearch' shortcode. By exploiting this vulnerability, attackers can include and execute arbitrary files on the server, potentially leading to the execution of malicious PHP code. The affected products include various versions of WordPress plugins. To remediate this vulnerability, users are advised to update their WordPress plugins to a version that has patched this issue. The potential danger posed by this vulnerability includes bypassing access controls, obtaining sensitive data, and achieving code execution, especially if "safe" file types like images can be uploaded and included on the server.

Explore Beyond the CVE Basics with Recorded Future's Vulnerability Intelligence

Note: This is just a basic overview providing quick insights into CVE-2023-5099 information. Gain full access to comprehensive CVE data, risk scores, prioritization, and mitigation data through Recorded Future's Vulnerability Intelligence:
  • Prioritize with Risk-Based Scoring
  • Explore the Extensive Vulnerability Database
  • Receive Early Alerts on Emerging CVEs
  • Focus on Critical Exploitable Vulnerabilities
  • Streamline Remediation with Integration Options