CVE-2023-50716

CVSS 3.1 Score 9.6 of 10 (high)

Details

Published Mar 6, 2024
CWE ID 416

Summary

CVE-2023-50716 is a vulnerability that affects eProsima Fast DDS, a C++ implementation of the Data Distribution Service standard. Versions prior to 2.13.0, 2.12.2, 2.11.3, 2.10.3, and 2.6.7 are vulnerable to a bad-free error caused by an invalid DATA_FRAG Submessage. This can lead to the remote termination of the Fast-DDS process. When an invalid Data_Frag packet is sent, it tries to release memory without initialization, resulting in the 'bad-free' error. The issue is fixed in versions 2.13.0, 2.12.2, 2.11.3, 2.10.2, and 2.6.7 of eProsima Fast DDS.

Explore Beyond the CVE Basics with Recorded Future's Vulnerability Intelligence

Note: This is just a basic overview providing quick insights into CVE-2023-50716 information. Gain full access to comprehensive CVE data, risk scores, prioritization, and mitigation data through Recorded Future's Vulnerability Intelligence:
  • Prioritize with Risk-Based Scoring
  • Explore the Extensive Vulnerability Database
  • Receive Early Alerts on Emerging CVEs
  • Focus on Critical Exploitable Vulnerabilities
  • Streamline Remediation with Integration Options