CVSS 3.1 Score 5.4 of 10 (medium)


Published Oct 20, 2023
Updated: Nov 7, 2023


CVE-2023-5050 is a vulnerability found in the Leaflet Map plugin for WordPress, affecting versions up to and including 3.3.0. The vulnerability allows authenticated attackers with contributor level and above permissions to inject arbitrary web scripts into pages using shortcodes, leading to stored cross-site scripting (XSS) attacks. This means that whenever a user accesses an injected page, the injected web scripts will execute. The risk score associated with this vulnerability is 25 out of 100, indicating a medium severity level. To remediate this vulnerability, users should update to a version of the Leaflet Map plugin that is beyond 3.3.0, as newer versions are likely to have addressed the insufficient input sanitization and output escaping issues present in the affected versions. If left unaddressed, this vulnerability poses a potential danger to organizations using the vulnerable Leaflet Map plugin as it could be exploited to execute malicious scripts and potentially compromise user data or perform further attacks on the targeted systems.


Explore Beyond the CVE Basics with Recorded Future's Vulnerability Intelligence

Note: This is just a basic overview providing quick insights into CVE-2023-5050 information. Gain full access to comprehensive CVE data, risk scores, prioritization, and mitigation data through Recorded Future's Vulnerability Intelligence:
  • Prioritize with Risk-Based Scoring
  • Explore the Extensive Vulnerability Database
  • Receive Early Alerts on Emerging CVEs
  • Focus on Critical Exploitable Vulnerabilities
  • Streamline Remediation with Integration Options