CVE-2023-50291

CVSS 3.1 Score 7.5 of 10 (high)

Details

Published Feb 9, 2024
Updated: Feb 15, 2024
CWE ID 522

Summary

CVE-2023-50291 is an Insufficiently Protected Credentials vulnerability in Apache Solr. This vulnerability affects Apache Solr versions 6.0.0 through 8.11.2 and versions 9.0.0 before 9.3.0. The issue arises from the "/admin/info/properties" endpoint, which publishes the Solr process' Java system properties, including sensitive ones like "basicauth" and "aws.secretKey", without proper protection. This exposes the credentials in the user interface of the Solr Admin page, making them visible to unauthorized users with the "config-read" permission in Solr Clouds with Authorization enabled. To remediate this vulnerability, users are advised to upgrade to either version 9.3.0 or 8.11.3, which contain fixes for this issue. The vulnerability has a high base severity rating of 7.5 and poses a potential danger to organizations by compromising confidentiality if exploited by an attacker over the network without requiring any privileges or user interaction

Share

Explore Beyond the CVE Basics with Recorded Future's Vulnerability Intelligence

Note: This is just a basic overview providing quick insights into CVE-2023-50291 information. Gain full access to comprehensive CVE data, risk scores, prioritization, and mitigation data through Recorded Future's Vulnerability Intelligence:
  • Prioritize with Risk-Based Scoring
  • Explore the Extensive Vulnerability Database
  • Receive Early Alerts on Emerging CVEs
  • Focus on Critical Exploitable Vulnerabilities
  • Streamline Remediation with Integration Options