CVE-2023-50290

CVSS 3.1 Score 6.5 of 10 (medium)

Details

Published Jan 15, 2024
Updated: Jan 22, 2024
CWE ID 200

Summary

CVE-2023-50290 is a vulnerability known as "Exposure of Sensitive Information to an Unauthorized Actor" in Apache Solr. This vulnerability affects Apache Solr versions from 9.0.0 before 9.3.0. The issue arises from the Solr Metrics API, which publishes all unprotected environment variables available to each Solr instance, potentially exposing sensitive information. However, users can specify which environment variables to hide, and the default list is designed for known secret Java system properties. To remediate this vulnerability, users are advised to upgrade to version 9.3.0 or later, where environment variables are not published via the Metrics API. The potential danger of this vulnerability lies in the confidentiality impact it poses to organizations that use Apache Solr, as unauthorized actors may gain access to sensitive information through the exposed environment variables.

Explore Beyond the CVE Basics with Recorded Future's Vulnerability Intelligence

Note: This is just a basic overview providing quick insights into CVE-2023-50290 information. Gain full access to comprehensive CVE data, risk scores, prioritization, and mitigation data through Recorded Future's Vulnerability Intelligence:
  • Prioritize with Risk-Based Scoring
  • Explore the Extensive Vulnerability Database
  • Receive Early Alerts on Emerging CVEs
  • Focus on Critical Exploitable Vulnerabilities
  • Streamline Remediation with Integration Options