CVSS 3.1 Score 6.0 of 10 (medium)


Published Sep 22, 2023
Updated: Nov 7, 2023


CVE-2023-5002 is a vulnerability found in pgAdmin, affecting versions prior to 7.6. This vulnerability allows an authenticated user to run arbitrary commands on the server by exploiting a flaw in the pgAdmin server HTTP API's validation of the path selected to external PostgreSQL utilities such as pg_dump and pg_restore. The potential danger of this vulnerability lies in the ability for an attacker to execute arbitrary commands on the server, posing a threat to the organization's data integrity and availability. To remediate this vulnerability, organizations should update their pgAdmin installations to version 7.6 or later.

Explore Beyond the CVE Basics with Recorded Future's Vulnerability Intelligence

Note: This is just a basic overview providing quick insights into CVE-2023-5002 information. Gain full access to comprehensive CVE data, risk scores, prioritization, and mitigation data through Recorded Future's Vulnerability Intelligence:
  • Prioritize with Risk-Based Scoring
  • Explore the Extensive Vulnerability Database
  • Receive Early Alerts on Emerging CVEs
  • Focus on Critical Exploitable Vulnerabilities
  • Streamline Remediation with Integration Options