CVE-2023-49920

CVSS 3.1 Score 6.5 of 10 (medium)

Details

Published Dec 21, 2023
Updated: Dec 28, 2023
CWE ID 352

Summary

CVE-2023-49920 is a vulnerability affecting Apache Airflow versions 2.7.0 through 2.7.3. It allows an attacker to trigger a Directed Acyclic Graph (DAG) in a GET request without CSRF validation, enabling the execution of DAGs without user consent if a malicious website is opened in the same browser as the Airflow UI. The recommended remediation is to upgrade to version 2.8.0 or later, which is not affected by this vulnerability. The potential danger posed to an organization includes the unauthorized execution of DAGs, potentially leading to unintended actions or data breaches. The severity of this vulnerability is rated as MEDIUM with a base score of 6.5 according to NVD@NIST.gov, indicating the importance of addressing it promptly and upgrading to the patched version of Apache Airflow.

Explore Beyond the CVE Basics with Recorded Future's Vulnerability Intelligence

Note: This is just a basic overview providing quick insights into CVE-2023-49920 information. Gain full access to comprehensive CVE data, risk scores, prioritization, and mitigation data through Recorded Future's Vulnerability Intelligence:
  • Prioritize with Risk-Based Scoring
  • Explore the Extensive Vulnerability Database
  • Receive Early Alerts on Emerging CVEs
  • Focus on Critical Exploitable Vulnerabilities
  • Streamline Remediation with Integration Options