CVE-2023-49898

CVSS 3.1 Score 7.2 of 10 (high)

Details

Published Dec 15, 2023
Updated: Jan 5, 2024
CWE ID 77

Summary

CVE-2023-49898 is a vulnerability in the streampark project module that integrates Maven's compilation capability. It allows attackers to execute remote commands by inserting malicious commands into the compilation parameters of Maven. To exploit this vulnerability, an attacker would need to log in to the streampark system with system-level permissions. The risk level of this vulnerability is considered very low because generally only authorized users have access to the system and would not manually input dangerous commands. To mitigate this vulnerability, all users should upgrade to version 2.1.2 of streampark. The affected products include t4aRoK, t4aRoL, t4aRoJ, rJe-29, t4aRoM, rJe-2_, rJe-2-, rJe-3B, rJe-3A, rJe-3D, rJe-3C, and rJe-3E. The CVE ID for this vulnerability is CVE-2023-49898 and it has a base severity of HIGH according to NVD@NIST.gov.

Explore Beyond the CVE Basics with Recorded Future's Vulnerability Intelligence

Note: This is just a basic overview providing quick insights into CVE-2023-49898 information. Gain full access to comprehensive CVE data, risk scores, prioritization, and mitigation data through Recorded Future's Vulnerability Intelligence:
  • Prioritize with Risk-Based Scoring
  • Explore the Extensive Vulnerability Database
  • Receive Early Alerts on Emerging CVEs
  • Focus on Critical Exploitable Vulnerabilities
  • Streamline Remediation with Integration Options