CVE-2023-49145

CVSS 3.1 Score 5.4 of 10 (medium)

Details

Published Nov 27, 2023
Updated: Dec 1, 2023
CWE ID 79

Summary

CVE-2023-49145 is a vulnerability found in Apache NiFi versions 0.7.0 through 1.23.2. The vulnerability exists in the JoltTransformJSON Processor, which is susceptible to DOM-based cross-site scripting attacks. If an authenticated user with authorization to configure the processor visits a specially crafted URL, arbitrary JavaScript code can be executed within the user's session context. To mitigate this vulnerability, it is recommended to upgrade to either Apache NiFi version 1.24.0 or 2.0.0-M1. The vulnerability has a risk score of 25 and a base severity of MEDIUM according to NIST's National Vulnerability Database (NVD).

Share

Explore Beyond the CVE Basics with Recorded Future's Vulnerability Intelligence

Note: This is just a basic overview providing quick insights into CVE-2023-49145 information. Gain full access to comprehensive CVE data, risk scores, prioritization, and mitigation data through Recorded Future's Vulnerability Intelligence:
  • Prioritize with Risk-Based Scoring
  • Explore the Extensive Vulnerability Database
  • Receive Early Alerts on Emerging CVEs
  • Focus on Critical Exploitable Vulnerabilities
  • Streamline Remediation with Integration Options