CVE-2023-48230

CVSS 3.1 Score 9.8 of 10 (high)

Details

Published Nov 21, 2023
Updated: Nov 29, 2023
CWE ID 124
CWE ID 787

Summary

CVE-2023-48230 is a vulnerability in Cap'n Proto, a data interchange format and RPC system. Versions 1.0 and 1.0.1 of Cap'n Proto are affected when using the KJ HTTP library with WebSocket compression enabled. This vulnerability allows a remote peer to cause a buffer underrun, potentially leading to a crash and enabling a remote denial-of-service attack. Most users of Cap'n Proto and KJ are unlikely to be affected as this functionality is not commonly enabled. However, it is suspected that the Cloudflare Workers Runtime may be affected. To remediate this vulnerability, users should ensure that WebSocket compression is disabled by default or through the appropriate settings in the KJ HTTP library.

Explore Beyond the CVE Basics with Recorded Future's Vulnerability Intelligence

Note: This is just a basic overview providing quick insights into CVE-2023-48230 information. Gain full access to comprehensive CVE data, risk scores, prioritization, and mitigation data through Recorded Future's Vulnerability Intelligence:
  • Prioritize with Risk-Based Scoring
  • Explore the Extensive Vulnerability Database
  • Receive Early Alerts on Emerging CVEs
  • Focus on Critical Exploitable Vulnerabilities
  • Streamline Remediation with Integration Options