CVSS 3.1 Score 5.4 of 10 (medium)


Published Oct 16, 2023
Updated: Nov 7, 2023


CVE-2023-4783 is a vulnerability found in the Magee Shortcodes WordPress plugin version 2.1.1 and earlier. This vulnerability allows users with the contributor role and above to perform Stored Cross-Site Scripting (XSS) attacks. The plugin fails to validate and escape some of its shortcode attributes, which could lead to malicious code being executed on the affected page or post. There are 49 known instances of this vulnerability being exploited. To remediate this issue, users should update the Magee Shortcodes plugin to version 2.1.2 or later, which includes a fix for this vulnerability. If left unaddressed, this vulnerability poses a medium risk to organizations as it could potentially allow attackers to inject malicious scripts, leading to unauthorized actions or data theft on compromised WordPress sites using this plugin.


Explore Beyond the CVE Basics with Recorded Future's Vulnerability Intelligence

Note: This is just a basic overview providing quick insights into CVE-2023-4783 information. Gain full access to comprehensive CVE data, risk scores, prioritization, and mitigation data through Recorded Future's Vulnerability Intelligence:
  • Prioritize with Risk-Based Scoring
  • Explore the Extensive Vulnerability Database
  • Receive Early Alerts on Emerging CVEs
  • Focus on Critical Exploitable Vulnerabilities
  • Streamline Remediation with Integration Options