CVSS 3.1 Score 7.8 of 10 (high)


Published Sep 2, 2023
Updated: Feb 1, 2024
CWE ID 787
CWE ID 122


CVE-2023-4738 is a heap-based buffer overflow vulnerability found in the GitHub repository vim/vim prior to version 9.0.1848, affecting multiple products. The vulnerability has a base severity rating of HIGH with a base score of 7.8 out of 10. It requires user interaction and has no privilege requirements, but it can be exploited locally. The impact includes high integrity and confidentiality risks, with a CVSS vector string of CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H. The vulnerability poses a potential danger to organizations as it could allow an attacker to execute arbitrary code with elevated privileges on the affected systems. Remediation is advised by updating the vim/vim repository to version 9.0.1848 or higher to mitigate the risk associated with this vulnerability.

Leverage our Vulnerability Intelligence module to secure your systems now - get detailed insights on CVE-2024-37364. Book your demo today.


Explore Beyond the CVE Basics with Recorded Future's Vulnerability Intelligence

Note: This is just a basic overview providing quick insights into CVE-2023-4738 information. Gain full access to comprehensive CVE data, risk scores, prioritization, and mitigation data through Recorded Future's Vulnerability Intelligence:
  • Prioritize with Risk-Based Scoring
  • Explore the Extensive Vulnerability Database
  • Receive Early Alerts on Emerging CVEs
  • Focus on Critical Exploitable Vulnerabilities
  • Streamline Remediation with Integration Options