CVE-2023-47037

CVSS 3.1 Score 4.3 of 10 (medium)

Details

Published Nov 12, 2023
Updated: Nov 20, 2023
CWE ID 863

Summary

CVE-2023-47037 is a vulnerability affecting Apache Airflow versions before 2.7.3. Authenticated and DAG-view authorized users can exploit this vulnerability to modify certain details of DAG runs, including configuration parameters and start date. To remediate this vulnerability, users should upgrade to version 2.7.3 or later, which has addressed the issue. This vulnerability poses a potential danger to organizations using affected versions of Apache Airflow as it allows unauthorized modification of critical DAG run details, potentially leading to unauthorized access or disruption of workflows.

Explore Beyond the CVE Basics with Recorded Future's Vulnerability Intelligence

Note: This is just a basic overview providing quick insights into CVE-2023-47037 information. Gain full access to comprehensive CVE data, risk scores, prioritization, and mitigation data through Recorded Future's Vulnerability Intelligence:
  • Prioritize with Risk-Based Scoring
  • Explore the Extensive Vulnerability Database
  • Receive Early Alerts on Emerging CVEs
  • Focus on Critical Exploitable Vulnerabilities
  • Streamline Remediation with Integration Options