CVE-2023-46944

CVSS 3.1 Score 7.8 of 10 (high)

Details

Published Nov 28, 2023
Updated: Dec 4, 2023

Summary

CVE-2023-46944 is a vulnerability in GitKraken GitLens before version 14.0.0 that allows an attacker to execute arbitrary code through a specially crafted file in the Visual Studio Codes workspace trust component. The vulnerability affects multiple products, including trfa52, trfa53, trfa50, and trfa51. To remediate this vulnerability, users should update to GitKraken GitLens version 14.0.0 or later. This vulnerability poses a high danger to organizations as it has a base severity rating of HIGH, with potential impacts on confidentiality, integrity, and availability of affected systems.

Share

Explore Beyond the CVE Basics with Recorded Future's Vulnerability Intelligence

Note: This is just a basic overview providing quick insights into CVE-2023-46944 information. Gain full access to comprehensive CVE data, risk scores, prioritization, and mitigation data through Recorded Future's Vulnerability Intelligence:
  • Prioritize with Risk-Based Scoring
  • Explore the Extensive Vulnerability Database
  • Receive Early Alerts on Emerging CVEs
  • Focus on Critical Exploitable Vulnerabilities
  • Streamline Remediation with Integration Options