CVE-2023-46667

CVSS 3.1 Score 8.1 of 10 (high)

Details

Published Oct 26, 2023
Updated: Nov 3, 2023
CWE ID 532

Summary

CVE-2023-46667 is a vulnerability affecting Fleet Server versions 8.10.0 to 8.10.3. It allows enrolment tokens to be logged in plain text, potentially enabling an attacker to enrol an agent into an agent policy and gain access to secrets related to Elasticsearch and third-party services. Additionally, threat actors could exploit this vulnerability to enrol agents into clusters and send arbitrary events to Elasticsearch. The base severity of this vulnerability is rated as HIGH, with a base score of 8.1 out of 10. To remediate the issue, it is recommended to update Fleet Server to a version higher than 8.10.3, which addresses the vulnerability and removes the exposure of enrolment tokens in log files. This vulnerability poses a significant danger as it can lead to unauthorized access and compromise of sensitive information within an organization's infrastructure.

Explore Beyond the CVE Basics with Recorded Future's Vulnerability Intelligence

Note: This is just a basic overview providing quick insights into CVE-2023-46667 information. Gain full access to comprehensive CVE data, risk scores, prioritization, and mitigation data through Recorded Future's Vulnerability Intelligence:
  • Prioritize with Risk-Based Scoring
  • Explore the Extensive Vulnerability Database
  • Receive Early Alerts on Emerging CVEs
  • Focus on Critical Exploitable Vulnerabilities
  • Streamline Remediation with Integration Options