CVE-2023-46658

CVSS 3.1 Score 5.3 of 10 (medium)

Details

Published Oct 25, 2023
Updated: Nov 1, 2023
CWE ID 697

Summary

CVE-2023-46658, also known as Jenkins MSTeams Webhook Trigger Plugin vulnerability, affects versions 0.1.1 and earlier. This vulnerability arises from the plugin's use of a non-constant time comparison function, making it possible for attackers to use statistical methods to obtain a valid webhook token. The affected products are 't0TPtD' and 't0TPtC'. To remediate this vulnerability, users should update the Jenkins MSTeams Webhook Trigger Plugin to a version that is not affected. The potential danger posed by this vulnerability is rated as medium severity, with a base score of 5.3, confidentiality impact of low, and no integrity or availability impact.

Explore Beyond the CVE Basics with Recorded Future's Vulnerability Intelligence

Note: This is just a basic overview providing quick insights into CVE-2023-46658 information. Gain full access to comprehensive CVE data, risk scores, prioritization, and mitigation data through Recorded Future's Vulnerability Intelligence:
  • Prioritize with Risk-Based Scoring
  • Explore the Extensive Vulnerability Database
  • Receive Early Alerts on Emerging CVEs
  • Focus on Critical Exploitable Vulnerabilities
  • Streamline Remediation with Integration Options