CVE-2023-46589

CVSS 3.1 Score 7.5 of 10 (high)

Details

Published Nov 28, 2023
Updated: Jan 5, 2024
CWE ID 444

Summary

CVE-2023-46589 is an Improper Input Validation vulnerability in Apache Tomcat. This vulnerability affects Tomcat versions 11.0.0-M1 through 11.0.0-M10, 10.1.0-M1 through 10.1.15, 9.0.0-M1 through 9.0.82, and 8.5.0 through 8.5.95, and it occurs due to the incorrect parsing of HTTP trailer headers by Tomcat. Exploiting this vulnerability could lead to request smuggling when behind a reverse proxy, as a single request could be treated as multiple requests by Tomcat. To remediate this issue, users are advised to upgrade to version 11.0.0-M11 onwards, 10.1.16 onwards, 9.0.83 onwards, or 8.5.96 onwards, which contain the necessary fixes for this vulnerability.

Share

Explore Beyond the CVE Basics with Recorded Future's Vulnerability Intelligence

Note: This is just a basic overview providing quick insights into CVE-2023-46589 information. Gain full access to comprehensive CVE data, risk scores, prioritization, and mitigation data through Recorded Future's Vulnerability Intelligence:
  • Prioritize with Risk-Based Scoring
  • Explore the Extensive Vulnerability Database
  • Receive Early Alerts on Emerging CVEs
  • Focus on Critical Exploitable Vulnerabilities
  • Streamline Remediation with Integration Options