CVE-2023-4634

CVSS 3.1 Score 9.8 of 10 (high)

Details

Published Sep 6, 2023
Updated: Nov 7, 2023
CWE ID 73

Summary

CVE-2023-4634 is a critical vulnerability affecting the Media Library Assistant plugin for WordPress up to version 3.09. The vulnerability allows unauthenticated attackers to exploit insufficient controls on file paths, specifically the 'mla_stream_file' parameter from the ~/includes/mla-stream-image.php file, which processes images using Imagick(). As a result, attackers can supply files via FTP that enable directory listing, local file inclusion, and remote code execution. This vulnerability has a base severity score of 9.8 and poses high risks to organizations as it can lead to unauthorized access, data compromise, and potential disruption of services. To remediate this vulnerability, users are advised to update the affected plugin to a secure version and ensure their WordPress installations are kept up-to-date with the latest security patches.

Share

Explore Beyond the CVE Basics with Recorded Future's Vulnerability Intelligence

Note: This is just a basic overview providing quick insights into CVE-2023-4634 information. Gain full access to comprehensive CVE data, risk scores, prioritization, and mitigation data through Recorded Future's Vulnerability Intelligence:
  • Prioritize with Risk-Based Scoring
  • Explore the Extensive Vulnerability Database
  • Receive Early Alerts on Emerging CVEs
  • Focus on Critical Exploitable Vulnerabilities
  • Streamline Remediation with Integration Options